Jump to content
×
×
  • Create New...
  • Please do not post a message for the purpose of insulting, incitement to hatred, sexual remarks and any other which does not respect our terms of use !

 aide urgente Problème script boutique


JunsHam
 Share

Recommended Posts

Bonjour tout le monde, je tiens tout dabord à m'excuser pour cette présentation assez bâclé, il est 7h du matin je ne suis pas assez reveillé.

Je vais droit au but, j'utilise YOURHABBO CMS afin de le modifier et peut être faire un site de vente mais pour cela je commence par tenter de régler tout les petits soucis.
Cela fait maintenant 3H que j'essaie de faire fonctionner mon script DEDIPASS par tout les moyens, en effet j'ai installer mon script pour l'achat de CREDITS il fonctionne quand je rentre mon CODE TEST (CODE VALIDE) , mais il ne me donne pas mon crédit acheter de plus il ne mentionne pas sur la DB à la table sting_logs_payements l'historique des paiements , j'ai l'impression que la base de donnée est mal connecter. alors ma question est celle-ci : Y'a t'il des utilisateurs de YOURHABBOCMS ? ou des personnes qui y ont déjà jeter un coup d'œil afin de me venir en aide ?

Je vous fait une capture d'écran du code en question peut être il y'a une erreur que je n'ai pas su voir : 

Pouvez vous m'aider en PV ou ICI ou même sur Discord.


PS : Une fois que j'aurais la solution je mettrai à jour mon topic afin de partager la solution

Merci beaucoup pour votre aide et votre temps

inshare.PNG

Link to comment
Share on other sites

Salut,

 

As-tu : 

 

- Bien revérifié les infos de ta db, cela comprend le domaine, le nom de ta db, l'username et le mot de passe.

- Bien vérifié que ton global.php contient ou appel ta fonction getDB()

- Fais un try/catch pour la connexion et fais un setAtrribute pour avoir des erreurs précise sur les requêtes de ta DB

try {
            $db =  new PDO('mysql:host=localhost;dbname=dbdiet;charset=utf8', 'root', '');
            $db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);

            return $db;

        }
        catch(exception $e) {
            die('Erreur '.$e->getMessage());
        }

- Bien vérifié que tu n'avais pas de log dans sting_users non plus auquel cas ce serai ta première requête qui contient des paramètres ne fonctionnant pas.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share